Firefox: Wrong Plugin Version Detected

To resolve the following error: Firefox has prevented the outdated plugin “XXXX” from running on …, do the following…

Prerequisites

Consindering that the system version of Adobe Flash Plugin is up-to-date (pacman -Syu), the following is most probably the cause of the error. During the system update, the Firefox was running and as a result, it did not update the pluginreg.dat file.

Solution

  1. Close Firefox.
  2. Remove the pluginreg.dat file by:
    rm ~/.mozilla/firefox/PROFILE-IDENTIFIER.default/pluginreg.dat
    (the PROFILE-IDENTIFIER differs as per Firefox installation.)

Source

Advertisements
This entry was posted in Browser, BSD, Linux, Security and tagged , , , , , , . Bookmark the permalink.