ArchLinux: Veracrypt KISS

After today’s update (2017-06-08), veracrypt cannot be installed “due to unresolvable dependencies“. Yet, another KISS example missing the “simple” part…

No Matter How Hard I Try…

$ yaourt -S veracrypt
resolving dependencies...
warning: cannot resolve "wxgtk>=3.0", a dependency of "veracrypt"
:: The following package cannot be upgraded due to unresolvable dependencies:
      veracrypt

:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...
 there is nothing to do
$ yaourt -S veracrypt
resolving dependencies...
warning: cannot resolve "wxgtk>=3.0", a dependency of "veracrypt"
:: The following package cannot be upgraded due to unresolvable dependencies:
      veracrypt

:: Do you want to skip the above package for this upgrade? [y/N] N
error: failed to prepare transaction (could not satisfy dependencies)
:: veracrypt: requires wxgtk>=3.0

Manual installation of the requested wxgtk>=3.0 does not help either:

$ yaourt -S wxgtk3

Trying Harder

A workaround using the AUR version:

$ yaourt -S veracrypt-git

which works fine. It’s a shame that the official community repository version does not…

Update

The package dependency was properly corrected the same day later. This post remains here as a note to remind in what awkward situations one can get with a rolling update distribution, and that…

Arch Linux is a tough playground. Beware, behold and KISS!

Advertisements
This entry was posted in Linux and tagged , , , . Bookmark the permalink.